Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Can't open BASCOM AVR files with version 2.0.8.3

 
Post new topic   Reply to topic    www.mcselec.com Forum Index -> Various
View previous topic :: View next topic  
Author Message
hzz

Bascom Member



Joined: 20 Feb 2007
Posts: 270

spain.gif
PostPosted: Sun Aug 02, 2020 1:09 pm    Post subject: Can't open BASCOM AVR files with version 2.0.8.3 Reply with quote

When I double click on a .prj, .bas or .inc file it alwasys opens with 2.0.8.2 even if I force open with 2.0.8.3
If I rename the 2.0.8.2 folder then these files open with 2.0.8.1 no matter if I set in Windows that they should be opened with 2.0.8.3


V2.0.8.3 opens fine and once it is open I can open .prj, .bas or .inc files from the IDE, but never double clicking on the files

(BASCOM-AVR version : 2.0.8.3 )
Back to top
View user's profile
hzz

Bascom Member



Joined: 20 Feb 2007
Posts: 270

spain.gif
PostPosted: Sun Aug 02, 2020 1:34 pm    Post subject: Solved Reply with quote

I have solved by renaming all my previous versions of BASCOM
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 5060
Location: Holland

blank.gif
PostPosted: Sun Aug 02, 2020 7:34 pm    Post subject: Reply with quote

it has nothing to do with bascom. it is the windows file association you need to change.
in explorer right click the prj file and then chose 'open with'

_________________
Mark
Back to top
View user's profile Visit poster's website
hzz

Bascom Member



Joined: 20 Feb 2007
Posts: 270

spain.gif
PostPosted: Sun Aug 02, 2020 11:38 pm    Post subject: Reply with quote

Thanks Mark. Thats what I did. It used to work with previous versions but for some reason Windows didn't want to open the files with 2.0.8.3 until there was no other choice.
Back to top
View user's profile
Endy64

Bascom Member



Joined: 06 Dec 2006
Posts: 18
Location: Slovenia

slovenia.gif
PostPosted: Thu Aug 06, 2020 2:54 pm    Post subject: Reply with quote

PostPosted: Sun Aug 02, 2020 7:34 pm Post subject:
it has nothing to do with bascom. it is the windows file association you need to change.
in explorer right click the prj file and then chose 'open with'

This not work to me also!
In the previous version of the software, this worked, but not in this one.
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 5060
Location: Holland

blank.gif
PostPosted: Thu Aug 06, 2020 8:48 pm    Post subject: Reply with quote

which window do you use?

Maybe you need to be admin to set the file association.

The normal way in Windows 10/7 :
Open Control Panel
Control Panel Home
Default Programs
Set Associations
Select a file type in the list and click Change Program.

but again, this is not something that bascom changes. i could do that in the setup but i chose not to mess up bas/prj/inc extension since it could be used by other programs too.
I did consider to include this function in the options however.

_________________
Mark
Back to top
View user's profile Visit poster's website
Endy64

Bascom Member



Joined: 06 Dec 2006
Posts: 18
Location: Slovenia

slovenia.gif
PostPosted: Sat Aug 08, 2020 7:46 am    Post subject: Reply with quote

albertsm wrote:
which window do you use?

Maybe you need to be admin to set the file association.

The normal way in Windows 10/7 :
Open Control Panel
Control Panel Home
Default Programs
Set Associations
Select a file type in the list and click Change Program.

but again, this is not something that bascom changes. i could do that in the setup but i chose not to mess up bas/prj/inc extension since it could be used by other programs too.
I did consider to include this function in the options however.





Iíve tried that too, but it doesnít work. I cannot set Bascom AVR as the default program. File associattions does not work.
I can make an association with any program but in no way with bascom AVR

The AVR Icon is not in preferred and also is not in other programs.

Even i use
Browse
program files (x86)
MCS electronics
BASCAVR2083
and click on bascavr icon nothing happen.

Also is strange why bascom AVR icon is not present in default program windov.
If i made installation of previus version of bascom is automaticaly there in default programs but with fresh new version the icon disappere.

I use windows 7 ultimate, i try also on win 8 - the same situation. Also Admin doesn't help

Best regards
Back to top
View user's profile
six1

Bascom Expert



Joined: 27 Feb 2009
Posts: 552

germany.gif
PostPosted: Sat Aug 08, 2020 8:30 am    Post subject: Reply with quote

the easy way is to rename old 2.0.8.2 Folder.
Next Time you click .bas file, windows will ask for default Program to open. Then select new Bascom.exe in 2.0.8.3 Folder

works 100%

_________________
For technical reasons, the signature is on the back of this message.
Back to top
View user's profile
plouf

Bascom Member



Joined: 19 Jan 2012
Posts: 27
Location: Athens,Greece

greece.gif
PostPosted: Sat Aug 08, 2020 8:32 am    Post subject: Reply with quote

have to agree nothing to do with BASCOM

can you try set up default program for .bas something else , for example notepad ?
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 5060
Location: Holland

blank.gif
PostPosted: Sat Aug 08, 2020 11:14 am    Post subject: Reply with quote

make sure to have admin rights and also to check : always use the selected program to open this kind of file

The only change between 2082 and 2083 is that the program is code signed. So you can be sure it is from MCS. Maybe that plays a role. Can not imagine why/how but you never know.

Associations are stored in the registry. you could alter that too but i think that the normal windows function to set/change it, should be used and work.

_________________
Mark
Back to top
View user's profile Visit poster's website
Endy64

Bascom Member



Joined: 06 Dec 2006
Posts: 18
Location: Slovenia

slovenia.gif
PostPosted: Mon Aug 10, 2020 7:47 am    Post subject: Reply with quote

plouf wrote:
have to agree nothing to do with BASCOM

can you try set up default program for .bas something else , for example notepad ?


That's exactly what I did, there was no program association problem with all the other programs. Now I have made an association with Bascom 8051 so I can immediately see that these are bascom programs. Of course, double-clicking does not open the right program.

That's why I'm confused. Why I can make an association with other programs, but I can not with Bascom AVR.

Best regards
Back to top
View user's profile
EDC

Bascom Expert



Joined: 26 Mar 2014
Posts: 692

poland.gif
PostPosted: Mon Aug 10, 2020 8:27 am    Post subject: Reply with quote

Solution 1.
Problem is that Windows don`t load new instance into "icons you may choose" so for new Bascom instance better is choose "search/explore my computer for open this file" and choose EXE file direct in the folder you explore on your computer.

Open this file with -> Choose another application -> More applications -> at the very bottom of the list -> Search another application on this computer Wink

Solution 2.
On my PC`s I have many Bascom instances installed and when I want to change which one should open my *.bas, *.inc files I`m using this simple free program -> LINK.
I`m using it for years and it work for me on the Win7 and Win10 too. This is the quick way for me Very Happy
Simply find "bas" extention, double click on that showed blue line and change path to the new Bascom instance.
Back to top
View user's profile Visit poster's website
Endy64

Bascom Member



Joined: 06 Dec 2006
Posts: 18
Location: Slovenia

slovenia.gif
PostPosted: Mon Aug 10, 2020 9:34 am    Post subject: Reply with quote

EDC wrote:
Solution 1.
Problem is that Windows don`t load new instance into "icons you may choose" so for new Bascom instance better is choose "search/explore my computer for open this file" and choose EXE file direct in the folder you explore on your computer.

Open this file with -> Choose another application -> More applications -> at the very bottom of the list -> Search another application on this computer Wink

Solution 2.
On my PC`s I have many Bascom instances installed and when I want to change which one should open my *.bas, *.inc files I`m using this simple free program -> LINK.
I`m using it for years and it work for me on the Win7 and Win10 too. This is the quick way for me Very Happy
Simply find "bas" extention, double click on that showed blue line and change path to the new Bascom instance.



Thank you a lot, now is fixed and working!
Best regards.

The other easy way is just renaming the bascavr.exe to bascomavr.exe, and fix the file asociation is no problem.
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 5060
Location: Holland

blank.gif
PostPosted: Mon Aug 10, 2020 1:32 pm    Post subject: Reply with quote

great tool EDC.
Nirsoft has many usable tools.

I added an option to bascom to set the file association for bas,prj and inc files.

_________________
Mark
Back to top
View user's profile Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    www.mcselec.com Forum Index -> Various All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum