Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

probleem met oplade EDB

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.mcselec.com Forum Index -> BASCOM-EDB
View previous topic :: View next topic  
Author Message
geertie58

Bascom Member



Joined: 23 May 2014
Posts: 4
Location: St Eloois Vijve

belgium.gif
PostPosted: Sat May 31, 2014 1:16 am    Post subject: probleem met oplade EDB Reply with quote

hallo beste vrienden van EDB,
ik heb een EDB met STK module(zelf gebouwd)maar ik krijg niets geprogrammeerd in dat ding. krijg steeds de melding 'could not identify chip with ID:000000. als ik dit venster afklik krijg ik een nieuw venster waar idd staat dat hij een ander chip zoekt nl at80s1200, bovenaan in het vensterte 'chip' kan ik wel veranderen naar atmega 88 maar kan het nergens bevestigen. dus sluiten maar en opnieuw proberen met hetzelfde gevolg...
kan iemand me helpen a.u.b. ik worstel nu al maanden met dat probleem, word er depri van....

vriendelijke groeten
Geert
Back to top
View user's profile
Frankeman

Bascom Member



Joined: 11 Aug 2004
Posts: 945
Location: the Netherlands

netherlands.gif
PostPosted: Sat May 31, 2014 7:50 am    Post subject: Reply with quote

Hi,

This is an english forum, try to write in english please so other people can understand it too.

And now the (probably) answer to your question.

Put the following line in the source code at line number 1 and try to progam again.

$regfile = "m88def.dat"


Frank.
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 4723
Location: Holland

blank.gif
PostPosted: Sat May 31, 2014 8:43 pm    Post subject: Reply with quote

if English is a problem you can write to support.
_________________
Mark
Back to top
View user's profile Visit poster's website
geertie58

Bascom Member



Joined: 23 May 2014
Posts: 4
Location: St Eloois Vijve

belgium.gif
PostPosted: Sun Jun 01, 2014 8:50 am    Post subject: Reply with quote

hallo Frank,

i do my best to write in english,
This is my program i want to put in the m88
$regfile = "m88def.dat"
$crystal = 8000000
config pinb.7 = input
config pind.1 = output
do
port d.1 = pinb.7
loop
end
you see it's very simple.
first i compile (F4) then write to chip (F7)
the LED D3 on the EDB board is flashing and i get an error on screen : could not idetify chip with ID:000000
i think its a hardware problem becouse last year this board was working properly but cinse i have a new(old) computer.
the LPT port is working properly with my printer (HP690)
please help my
best regards
Geert
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 4723
Location: Holland

blank.gif
PostPosted: Sun Jun 01, 2014 10:02 pm    Post subject: Reply with quote

hi

when the LED is flashing, it means the bootloader is active. Why dont you use the bootloader?
- select programmer : MCS bootloader, 38400 baud. reset : DTR
- then press F4 and it should program the micro.

no need to use the stk programmer.

_________________
Mark
Back to top
View user's profile Visit poster's website
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.mcselec.com Forum Index -> BASCOM-EDB All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum