Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

problemen met LCD

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.mcselec.com Forum Index -> BASCOM-EDB
View previous topic :: View next topic  
Author Message
guusberens

Bascom Member



Joined: 07 Oct 2010
Posts: 2

netherlands.gif
PostPosted: Thu Oct 14, 2010 9:18 am    Post subject: problemen met LCD Reply with quote

Hallo allemaal,

Ik heb een Bascom en nu wil ik mijn LCD 16 * 2 scherm aan de praat krijgen.

Mijn probleem is dat als ik een standaard programma probeer te laten verschijnen op mijn LCD dat ik er niks op komt te staan. de achtergrond verlichting brand wel en ik zie op mn scherm een paar blokjes die dan langzaam weer verdwijnen. weet iemand waar het probleem ligt en weet iemand misschien een oplossing. Zou er misschien een component kapot zijn of iets dergelijks. Het ligt volgens mij niet aan het LCD scherm zelf want ik heb ook al een andere geprobeerd.

Alvast bedankt
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 5071
Location: Holland

blank.gif
PostPosted: Thu Oct 14, 2010 1:30 pm    Post subject: Re: problemen met LCD Reply with quote

guusberens wrote:
Hallo allemaal,

Ik heb een Bascom en nu wil ik mijn LCD 16 * 2 scherm aan de praat krijgen.

Mijn probleem is dat als ik een standaard programma probeer te laten verschijnen op mijn LCD dat ik er niks op komt te staan. de achtergrond verlichting brand wel en ik zie op mn scherm een paar blokjes die dan langzaam weer verdwijnen. weet iemand waar het probleem ligt en weet iemand misschien een oplossing. Zou er misschien een component kapot zijn of iets dergelijks. Het ligt volgens mij niet aan het LCD scherm zelf want ik heb ook al een andere geprobeerd.

Alvast bedankt


The MCS Forum only allows English posts.
You have an EDB board and problems with the LCD display.
Are the jumpers installed for the LCD ?
Did you load a sample that uses the LCD ?
The EDB does come with CD-ROM and samples. Did you test such a sample?
Was the EDB new? Or did it work before? As delivered, the display shows some text.
Since you see 'blocks' it means the contrast is ok.

Maybe your processor is defective, in that case you need to replace the processor.

Make sure you do not connect other electronics to the pins used by the LCD.

Here is a simple sample:

'--------------------------------------------------------------
' EDBexperiment7.bas
' Experiment 7 for the Educational Development Board
' (c) 1995-2006, MCS Electronics
' Fileversion 1.0
'--------------------------------------------------------------
'
'Purpose:
'This program uses an LCD display
'
'Conclusions:
'You should be able to use an LCD

$regfile = "m88def.dat"
$crystal = 8000000

'Config Lcd Sets The Portpins Of The Lcd
Config Lcdpin = Pin , Db4 = Portb.2 , Db5 = Portb.3 , Db6 = Portb.4 , Db7 = Portb.5 , E = Portb.1 , Rs = Portb.0
Config Lcdbus = 4 'Select 4 bits mode
Config Lcd = 16 * 2 '16*2 type LCD screen
'You can define your own LCD chars with the Deflcdchar statement
'And the Bascom build in LCD Designer, Tools -> LCD Designer menu
Cursor Off Noblink 'No cursor

Cls 'This clears the LCD

Do
Locate 1 , 1 : Lcd "Hello World "
Locate 2 , 1 : Lcd " "
Wait 1
Loop

End

_________________
Mark
Back to top
View user's profile Visit poster's website
guusberens

Bascom Member



Joined: 07 Oct 2010
Posts: 2

netherlands.gif
PostPosted: Thu Oct 14, 2010 4:34 pm    Post subject: Reply with quote

Yes I have problems with my LCD display. I see nothing on my LCD display when I load up the program for the LCD.
When I use the potmeter I see some blocks on the LCD. But the blocks goes slowly away in about 1 second.

Do you now what the problem is?
Maybe some components are defect or something like that?
Can you explane this problem?
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 5071
Location: Holland

blank.gif
PostPosted: Sat Oct 16, 2010 8:54 pm    Post subject: Reply with quote

Please answer all the questions i asked.
Is this a new board or a used one?
Did it worked before?
It appears that either the jumpers for the LCD are not set, or that the processor is not working.

to test the processor, see if all the pins used by the lcd can toggle logic level.
for example :
$regfile="m88def.dat"
$crystal=8000000
config portb=output
do
toggle portb
waitms 1000
loop

now connect a led and series resitor to the port B pins, and see if the led goes on/off.
do this for all pins used by the lcd.
If they change it means the pins used by the lcd are ok. when you used a new lcd, there is something else going on. you can best contact support@

_________________
Mark
Back to top
View user's profile Visit poster's website
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.mcselec.com Forum Index -> BASCOM-EDB All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum