Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

How to use Timer0 in Siumulator

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.mcselec.com Forum Index -> BASCOM-AVR Archive
View previous topic :: View next topic  
Author Message
mfulde

Bascom Member



Joined: 24 Apr 2007
Posts: 9
Location: Lonsee, Germany

germany.gif
PostPosted: Wed Dec 05, 2007 3:46 pm    Post subject: How to use Timer0 in Siumulator Reply with quote

Hi @all, I'm new in BASCOM-AVR but I have a problem in using the AVR Simulator with Timer0.

I wrote a simple programm for ATmega128:

$regfile = "m128def.dat"
$crystal = 16000000
$hwstack = 32
$swstack = 32
$framesize = 40
$baud = 38400

Dim W As Word
W = 0

Config Timer0 = Timer , Prescale = 1
On Timer0 Myisr
ENABLE INTERRUPTS
ENABLE TIMER2

DO
LOOP

MYISR:
Incr W
Print "*";
RETURN


I tried to simulate the program in the simulator. I tried to click on the OVF0 button as described in HELP but nothing appears. I thing, the ISR will not be started. hmmmmm Confused

Do somebody know this problem?
Is it a problem of the simulator?
Whats wrong with my code or my understanding?

Best regards, Markus

_________________
MaFu
Back to top
View user's profile
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.mcselec.com Forum Index -> BASCOM-AVR Archive All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum