Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

can bus sleep problem

 
Post new topic   Reply to topic    www.mcselec.com Forum Index -> BASCOM-AVR
View previous topic :: View next topic  
Author Message
Ghitab

Bascom Member



Joined: 25 Sep 2012
Posts: 8

PostPosted: Fri May 10, 2019 6:38 am    Post subject: can bus sleep problem Reply with quote

Hi. I made a system that read a car remote control and count number of button press, then set some ouputs acording to number I set . System works ok for couple of days and then no more wake up . I use atmega16m1 with TJA1055 as can transceiver and voltage regulator for the system is driven by INH pin of tja. When goes to sleep , tja cuts power to atmega and stay in low power consumption mode. When a can frame wakes tja from sleep, INH pin is high again and have again voltage to atmega. I study tja 1055 pdf but cant figure why system not wake up from time to time. Any ideea is welcome.
Thank you.

(BASCOM-AVR version : 2.0.8.1 )
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 4736
Location: Holland

blank.gif
PostPosted: Sat May 11, 2019 2:39 pm    Post subject: Reply with quote

ok, so you cut the complete power of the micro?
why not using a sleep mode of the processor?

maybe the rise time of the power is not ok. i guess the processor does not start up. otherwise it would work. try different xtal clock times. depending on the rise time of the power supply some chips have problems.

_________________
Mark
Back to top
View user's profile Visit poster's website
Ghitab

Bascom Member



Joined: 25 Sep 2012
Posts: 8

PostPosted: Sun May 19, 2019 3:33 pm    Post subject: Reply with quote

Thank you Albert for advice. I replace crystal from 16mhz to 4 mhz and seems ok so far, will test more.
I configure fuse to have 14ck startup time without aditional delay but when I measure time from apply vcc and first instruction(set ouput for can transceiver) I have around 4.2 ms. I use Cksel(3-0) 1101 and sut1=0, sut0=1 and 4mhz crystal.
Thank you.
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    www.mcselec.com Forum Index -> BASCOM-AVR All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum