Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

USART timing

 
Post new topic   Reply to topic    www.mcselec.com Forum Index -> Various
View previous topic :: View next topic  
Author Message
Flash

Bascom Member



Joined: 03 Feb 2006
Posts: 152
Location: EU

blank.gif
PostPosted: Wed Dec 19, 2018 2:44 pm    Post subject: USART timing Reply with quote

What is the minimum USART delay time between send (Tx) data and receive (Rx) data, with Atmega at 16MHz clk, and Baud=250k? I have max 1mS between Tx/Rx, is that enough?
I have problem with receiving data after the slave is received valid command from Atmega, with logic analayzer I can see that slave respond (after 1ms) with correct 30 bytes (clean bytes not chr) of data on Atmega's query, but atmega don't see even one byte when slave respond, green on the picture (I use Inputbin command, Ischarwaiting is always 0).
Thanks in advance.

_________________
A clever person solves a problem. A wise person avoids it. Albert Einstein
Back to top
View user's profile
Flash

Bascom Member



Joined: 03 Feb 2006
Posts: 152
Location: EU

blank.gif
PostPosted: Thu Dec 20, 2018 10:56 am    Post subject: Reply with quote

Resolved, the problem was in cheap Mad defective cable on Rx line... By the way USART delay time between send (Tx) data and
received (Rx) data now is 5us and USART works without any problems on 250k.

_________________
A clever person solves a problem. A wise person avoids it. Albert Einstein
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    www.mcselec.com Forum Index -> Various All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum