Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Reading wav file on sd card

 
Post new topic   Reply to topic    www.mcselec.com Forum Index -> BASCOM-AVR
View previous topic :: View next topic  
Author Message
atmega64

Bascom Member



Joined: 23 Feb 2005
Posts: 269
Location: ITALY

italy.gif
PostPosted: Wed Apr 08, 2015 3:59 pm    Post subject: Reading wav file on sd card Reply with quote

Hi,
I started a project started a little 'time ago, to play a wav file ...
Attached is the circuit and the code that I use ...

I have the following error:

? Starting ...
Initializing file system ...
Error: 227 at Init file system!

Anyone can help me, thanks.

(BASCOM-AVR version : 2.0.7.8 )
Back to top
View user's profile Visit poster's website
bzijlstra

Bascom Ambassador



Joined: 30 Dec 2004
Posts: 1179
Location: Tilburg - Netherlands

netherlands.gif
PostPosted: Wed Apr 08, 2015 6:58 pm    Post subject: avr-dos error message... Reply with quote

If I am correct, your error-message is from AVR-DOS. How did you format your Sd-card, what type of SD-card is it? Have you tried different Sd-cards?

My 2 cents
Ben Zijlstra
Back to top
View user's profile Visit poster's website
atmega64

Bascom Member



Joined: 23 Feb 2005
Posts: 269
Location: ITALY

italy.gif
PostPosted: Wed Apr 08, 2015 8:39 pm    Post subject: Reply with quote

sd 512mb fat32

I have not tried with another sd ...

but the connections are ok?
Back to top
View user's profile Visit poster's website
Evert :-)

Bascom Expert



Joined: 18 Feb 2005
Posts: 2107

netherlands.gif
PostPosted: Wed Apr 08, 2015 9:15 pm    Post subject: Reply with quote

According the TXB0104 datasheet
Quote:
And make sure the VCCA ≤ VCCB
VCCA should not exceed VCCB

_________________
www.evertdekker.com Bascom code vault
Back to top
View user's profile Visit poster's website
atmega64

Bascom Member



Joined: 23 Feb 2005
Posts: 269
Location: ITALY

italy.gif
PostPosted: Thu Apr 09, 2015 10:24 am    Post subject: Reply with quote

I noticed ...

I have to change connections txb0104 ...

But replacing the micro with ATmega1284P, the code remains compatible? Question Question Question
Back to top
View user's profile Visit poster's website
atmega64

Bascom Member



Joined: 23 Feb 2005
Posts: 269
Location: ITALY

italy.gif
PostPosted: Fri Apr 10, 2015 7:43 am    Post subject: Reply with quote

Does This Work !!!

It was TXB0104 connected incorrectly ...

Thanks to all
Back to top
View user's profile Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    www.mcselec.com Forum Index -> BASCOM-AVR All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum