Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Problem with bootloader - chksum error

 
Post new topic   Reply to topic    www.mcselec.com Forum Index -> BASCOM-AVR
View previous topic :: View next topic  
Author Message
TSEYFARTH

Bascom Member



Joined: 01 Jul 2006
Posts: 1042

usa.gif
PostPosted: Fri Feb 20, 2015 7:25 am    Post subject: Problem with bootloader - chksum error Reply with quote

Hello all,

I am using an Atmega644PA-20 with a 20MHz external crystal. The bootloader is set for 9600 baud, and has the following set:
Config Print0 = portd.2 , Mode = Set
Config portd.2 = Output 'set the direction yourself

This same code appeared to work with a 16Mhz crystal (and the bootloader code was also set to 16MHz). However now, this new bootloader *only works when an AVRISP MKII is also plugged in. Without the AVRISP, an error occurs quickly in the process. Previously, and this may be coincidental, the bootloader worked perfectly when the bootloader, and the chip used a 16MHz crystal.

I have seen this before but never could isolate it or understand the problem.

Any ideas would be appreciated!
Thank you,
Tim


(BASCOM-AVR version : 2.0.7.8 )
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    www.mcselec.com Forum Index -> BASCOM-AVR All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum