Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Bascom Terminal Emulator malfunction ? Win 10 ?

 
Post new topic   Reply to topic    www.mcselec.com Forum Index -> BASCOM-AVR
View previous topic :: View next topic  
Author Message
autoguider

Bascom Member



Joined: 24 Sep 2007
Posts: 56
Location: Aachen

germany.gif
PostPosted: Wed Sep 11, 2019 9:54 pm    Post subject: Bascom Terminal Emulator malfunction ? Win 10 ? Reply with quote

Dear All,
I cannot get the build in Terminal emulator operating. I am running a 328 p on an Arduino UNO R3 hardware environment. I removed the Arduino bootloader and installed the MCS. Running very well.
The 328 p send messages to the PC that I can document e.g. with Putty. PC runs on Win 10 64 bit.
The Bascom Terminal emulator ran one tim and showed huge letters.
I restarted Bascom with the result that I have a yellow vertical line on the left hand side flickering.
Resizing of the window did not help.

A good advice is highly appreciated.

best regards
Christian

(BASCOM-AVR version : 2.0.8.1 , Latest : 2.0.8.2 )
Back to top
View user's profile
KenHorse

Bascom Member



Joined: 16 Jul 2004
Posts: 465

blank.gif
PostPosted: Thu Sep 12, 2019 6:46 pm    Post subject: Reply with quote

I've noticed that the Terminal Window background is black when you first bring it up but does change to the selected background color if you clear it
Back to top
View user's profile
autoguider

Bascom Member



Joined: 24 Sep 2007
Posts: 56
Location: Aachen

germany.gif
PostPosted: Thu Sep 12, 2019 10:51 pm    Post subject: Reply with quote

I have the blue background color.
In the window I do not see the data sent from the MCU
There is a vertical yellow line on the right hand side of the terminal emulator window e.g. after clearing the window.
But no data.
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 4774
Location: Holland

blank.gif
PostPosted: Fri Sep 13, 2019 9:05 am    Post subject: Reply with quote

either configure properly, or reset the settings. or update.
in this cases a small screen shot will help to show what you mean.

_________________
Mark
Back to top
View user's profile Visit poster's website
KenHorse

Bascom Member



Joined: 16 Jul 2004
Posts: 465

blank.gif
PostPosted: Fri Sep 13, 2019 4:06 pm    Post subject: Reply with quote

3 screenshots

1st is right after opening Terminal Window
2nd is after some serial data is received
3rd is right after CLEAR is done

Win 10, 64 bit Home Edition, Bascom 2.0.8.2
Back to top
View user's profile
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 4774
Location: Holland

blank.gif
PostPosted: Fri Sep 13, 2019 7:11 pm    Post subject: Reply with quote

that is odd. for me it is blue all the time.
can you send the xml settings file? (zipped) so i can check with your settings?

_________________
Mark
Back to top
View user's profile Visit poster's website
KenHorse

Bascom Member



Joined: 16 Jul 2004
Posts: 465

blank.gif
PostPosted: Fri Sep 13, 2019 7:21 pm    Post subject: Reply with quote

albertsm wrote:
that is odd. for me it is blue all the time.
can you send the xml settings file? (zipped) so i can check with your settings?


Which xml file? I only seem to have ones in the PINOUT directory
Back to top
View user's profile
Evert :-)

Bascom Expert



Joined: 18 Feb 2005
Posts: 2092

netherlands.gif
PostPosted: Fri Sep 13, 2019 10:43 pm    Post subject: Reply with quote

Click on help, then about, then on the link left of app data dir.
Mark needs the bascom-avr2082.xml file.

_________________
www.evertdekker.com Bascom code vault
Back to top
View user's profile Visit poster's website
KenHorse

Bascom Member



Joined: 16 Jul 2004
Posts: 465

blank.gif
PostPosted: Fri Sep 13, 2019 10:57 pm    Post subject: Reply with quote

Ahh thanks

It's attached
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    www.mcselec.com Forum Index -> BASCOM-AVR All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum