Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Bascom-51 & Windows-7. Problems...

 
Post new topic   Reply to topic    www.mcselec.com Forum Index -> BASCOM-8051
View previous topic :: View next topic  
Author Message
Alexander-Dan

Bascom Member



Joined: 13 Mar 2014
Posts: 63
Location: Bryansk - Russia

russia.gif
PostPosted: Fri Feb 26, 2016 9:02 am    Post subject: Bascom-51 & Windows-7. Problems... Reply with quote

Hi all Bascom-51 users!
I wanted to install the program in windows-7. Installation completed successfully.
But after the start I see an error message "Class not registered"

I tried to run a program with administrator permissions, change will solve the compatibility of the file properties.
But the problem is not corrected.
Maybe someone has information that can help me?

thanks in advance, Alexander
Back to top
View user's profile Visit poster's website
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 5071
Location: Holland

blank.gif
PostPosted: Fri Feb 26, 2016 10:11 pm    Post subject: Reply with quote

this is a case of wrong installation.
- install with admin rights
- reboot
- run the first time with admin rights

that should solve it. if not, let me know.

_________________
Mark
Back to top
View user's profile Visit poster's website
Alexander-Dan

Bascom Member



Joined: 13 Mar 2014
Posts: 63
Location: Bryansk - Russia

russia.gif
PostPosted: Sat Feb 27, 2016 6:22 am    Post subject: Reply with quote

Yes, I did just that.

after the error of program I closed the window with the text of the error.
But program remains in memory and require a lot of CPU power. Computer freezes
Back to top
View user's profile Visit poster's website
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 5071
Location: Holland

blank.gif
PostPosted: Sat Feb 27, 2016 10:49 am    Post subject: Reply with quote

which version do you try to install?
_________________
Mark
Back to top
View user's profile Visit poster's website
Alexander-Dan

Bascom Member



Joined: 13 Mar 2014
Posts: 63
Location: Bryansk - Russia

russia.gif
PostPosted: Sat Feb 27, 2016 12:52 pm    Post subject: Reply with quote

http://www.mcselec.com/index.php?option=com_docman&task=doc_download&gid=166&Itemid=54
2.0.14.0
Back to top
View user's profile Visit poster's website
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 5071
Location: Holland

blank.gif
PostPosted: Mon Feb 29, 2016 9:55 pm    Post subject: Reply with quote

When you have a full version i recommend to use the latest. if you use the demo, you can try this :
- Make a DOS/Command window with ADMIN rights
- CD to the Bascom application dir that you selected ie c:\program files\mcs electronics\bascom-8051
- type : REGSVR32 MFC42.DLL
You should receive a message that it registered ok.
- type : REGSVR32 MHCOMM32.OCX
You should receive a message that it registered ok.

now this OLE error should be gone.

_________________
Mark
Back to top
View user's profile Visit poster's website
albertsm

Administrator



Joined: 09 Apr 2004
Posts: 5071
Location: Holland

blank.gif
PostPosted: Mon Feb 29, 2016 9:55 pm    Post subject: Reply with quote

When you have a full version i recommend to use the latest. if you use the demo, you can try this :
- Make a DOS/Command window with ADMIN rights
- CD to the Bascom application dir that you selected ie c:\program files\mcs electronics\bascom-8051
- type : REGSVR32 MFC42.DLL
You should receive a message that it registered ok.
- type : REGSVR32 MHCOMM32.OCX
You should receive a message that it registered ok.

now this OLE error should be gone.

_________________
Mark
Back to top
View user's profile Visit poster's website
Alexander-Dan

Bascom Member



Joined: 13 Mar 2014
Posts: 63
Location: Bryansk - Russia

russia.gif
PostPosted: Tue Mar 01, 2016 4:28 am    Post subject: Reply with quote

REGSVR32 MFC42.DLL >> OK

REGSVR32 MHCOMM32.OCX >> Error!
module MHCOMM32.OCX is loaded, but could not make a call DllRegisterServer, error code: 0x80040201


I reboot the computer in Administrator mode and see the message:
Back to top
View user's profile Visit poster's website
Alexander-Dan

Bascom Member



Joined: 13 Mar 2014
Posts: 63
Location: Bryansk - Russia

russia.gif
PostPosted: Tue Mar 01, 2016 4:32 am    Post subject: Reply with quote

O!!!
I found a solution to this problem in a network: i performed registration of some files manually. Thanks for the help!
Back to top
View user's profile Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    www.mcselec.com Forum Index -> BASCOM-8051 All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum