Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Problem with comercial i2cslave library from MCS

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.mcselec.com Forum Index -> BASCOM-AVR Archive
View previous topic :: View next topic  
Author Message
Carlos

Bascom Member



Joined: 16 Mar 2006
Posts: 19

germany.gif
PostPosted: Sat Oct 18, 2014 3:08 pm    Post subject: Problem with comercial i2cslave library from MCS Reply with quote

Hello!
I use the new Version of I2C-Slave-lib:

comment = BASCOM-AVR USI I2C slave library
libversion = 2.0.7.7
date = 8 Jan 2014

I want to use an ATTiny2313 as a Slave and therefore used the following Code (having copied the *.Lib-Files to BASCOM/LIB !):

------------------------------------------------------------
$regfile = "attiny2313.dat"

$crystal = 8000000
$hwstack = 40
$swstack = 16
$framesize = 24
config USI = twislave , address = &H40
------------------------------------------------------------

This results in the following compiler-error (BASCOM 2077):

Unknown CONFIG parameter [USI]
Unknown CONFIG parameter [ADDress]

I'd appreciate if someone could give me some pointers towards the problems in my code.

Thanks in advance
Ernst
Back to top
View user's profile
Plons

Bascom Member



Joined: 24 May 2005
Posts: 434
Location: Hilversum - The Netherlands

netherlands.gif
PostPosted: Sat Oct 18, 2014 4:52 pm    Post subject: Reply with quote

You need to include the I2C library in your code. See Help file on how to use include
_________________
Bascom AVR ver 2.0.8.1
ProtectedParallelPortProgrammingDongle: http://www.aplomb.nl/TechStuff/PPPD/PPPD%20English.html
Dragon-lair: http://www.aplomb.nl/TechStuff/Dragon/Dragon.html
"leef met vlag en wimpel, maar hou het simpel"
Back to top
View user's profile
Carlos

Bascom Member



Joined: 16 Mar 2006
Posts: 19

germany.gif
PostPosted: Sun Oct 19, 2014 8:33 am    Post subject: Reply with quote

thank you, the cause was:
I must update the BASCOM Compiler from 2077 Build 2 to 2077 Build 4
problem solved!

Ernst
Back to top
View user's profile
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.mcselec.com Forum Index -> BASCOM-AVR Archive All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum