Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Search found 64 matches
www.mcselec.com Forum Index
Author Message
  Topic: mega128A and 2x16 LCD *SOLVED*
Robert_d1968

Replies: 8
Views: 271

PostForum: BASCOM-AVR Archive   Posted: Sun Feb 02, 2014 9:08 am   Subject: mega128A and 2x16 LCD *SOLVED*
I have a Jtag Ice mk II that I use in conjunction with Atmel Studio (ver 6.1) to set the fuse settings.
Jtag is enabled right now, but will be switched off later in favor of a boot loader.

It was ...
  Topic: mega128A and 2x16 LCD *SOLVED*
Robert_d1968

Replies: 8
Views: 271

PostForum: BASCOM-AVR Archive   Posted: Sat Feb 01, 2014 4:54 pm   Subject: mega128A and 2x16 LCD *SOLVED*
Ok I got it working with some code from the sample folder, but It would still not work until I switched to the internal
8 mhz oscillator.


And yes the potentiometer, helps quit a bit, I can see t ...
  Topic: mega128A and 2x16 LCD *SOLVED*
Robert_d1968

Replies: 8
Views: 271

PostForum: BASCOM-AVR Archive   Posted: Sat Feb 01, 2014 4:20 pm   Subject: mega128A and 2x16 LCD *SOLVED*
The potentiometer just adjust's the contrast of the 16 squares, in other words its not displaying nothing but the squares, no text and only on the first line.

It's almost like it never gets initial ...
  Topic: mega128A and 2x16 LCD *SOLVED*
Robert_d1968

Replies: 8
Views: 271

PostForum: BASCOM-AVR Archive   Posted: Sat Feb 01, 2014 3:31 pm   Subject: mega128A and 2x16 LCD *SOLVED*
Thanks for the reply,

Quote "Hi,
adjuse lcd contrast (16 dark squares)
LCD RW Pin to GND ?
M103C fuse ?
pin 52/53 & 63/64 ? see datasheet page 241"

I have the contrast LCD pin 3 goin ...
  Topic: 2077 official release
Robert_d1968

Replies: 23
Views: 2780

PostForum: BASCOM-AVR Archive   Posted: Sat Feb 01, 2014 12:17 pm   Subject: 2077 official release
Thank you very much,

I'm downloading it now, it looks very nice indeed...
  Topic: mega128A and 2x16 LCD *SOLVED*
Robert_d1968

Replies: 8
Views: 271

PostForum: BASCOM-AVR Archive   Posted: Sat Feb 01, 2014 12:10 pm   Subject: mega128A and 2x16 LCD *SOLVED*
Hello everybody,

I'm trying to get a 2x16 lcd working on my ATMEGA128A. I have tried the sample code in the sample folders, could not get it working, I also borrowed some sample code from a post he ...
  Topic: ATmega8 (PinB 0) output problem
Robert_d1968

Replies: 4
Views: 329

PostForum: BASCOM-AVR Archive   Posted: Thu Nov 21, 2013 5:51 am   Subject: ATmega8 (PinB 0) output problem
Thanks for the help guys,

The problem is solved Very Happy


It turns out that in the timer2 isr there was a: Toggle portb.0 in there...

I never really check the isr's so it went unnoticed by me ...
  Topic: ATmega8 (PinB 0) output problem
Robert_d1968

Replies: 4
Views: 329

PostForum: BASCOM-AVR Archive   Posted: Wed Nov 20, 2013 7:30 am   Subject: ATmega8 (PinB 0) output problem
Yes,

It is configured as such:
Config Portb = Output '- Set PORTB as Outputs
Portb = &HFF '- Set PORTB ou ...
  Topic: ATmega8 (PinB 0) output problem
Robert_d1968

Replies: 4
Views: 329

PostForum: BASCOM-AVR Archive   Posted: Mon Nov 18, 2013 7:05 am   Subject: ATmega8 (PinB 0) output problem
I'm having a problem controlling an ATMEG8 output.

I have all of port b set as outputs. I have timer one set up for pulse width modulation with the output on OC1A (pin 1 port b).
It's set up like ...
  Topic: Strange behavior, atmega88pa
Robert_d1968

Replies: 19
Views: 459

PostForum: BASCOM-AVR Archive   Posted: Mon Dec 31, 2012 11:34 am   Subject: Strange behavior, atmega88pa
Thank you for your help,

The circuit I'm working on does not need any precision what so ever, it just uses the resistance as a reference along the path to completion.

It's just a constant curren ...
  Topic: Strange behavior, atmega88pa
Robert_d1968

Replies: 19
Views: 459

PostForum: BASCOM-AVR Archive   Posted: Sun Dec 30, 2012 6:09 pm   Subject: Strange behavior, atmega88pa
I never said that there is something wrong with sub/end sub, Just that I did not work well for my application.

Switching to the labels/return seemed to correct this issue, weather or not it was re ...
  Topic: Strange behavior, atmega88pa
Robert_d1968

Replies: 19
Views: 459

PostForum: BASCOM-AVR Archive   Posted: Sun Dec 30, 2012 4:33 pm   Subject: Strange behavior, atmega88pa
That is not a working approach,

as far as :

Sub

End sub

I used this in the program at first, but for some reason it always did some strange things, so I switched to labels and returns.
Si ...
  Topic: Strange behavior, atmega88pa
Robert_d1968

Replies: 19
Views: 459

PostForum: BASCOM-AVR Archive   Posted: Sun Dec 30, 2012 12:55 pm   Subject: Strange behavior, atmega88pa
Well I have pretty much finished this project,

I changed from using:

Sub

end sub

to just using labels gosub and return. This fixed all of the strange behavior that the program was having ...
  Topic: Strange behavior, atmega88pa
Robert_d1968

Replies: 19
Views: 459

PostForum: BASCOM-AVR Archive   Posted: Tue Dec 18, 2012 3:16 pm   Subject: Strange behavior, atmega88pa
Hmmm,

I see what you mean by overlay, yes I could see where that could cause some problems if you were not careful.
Could save you some space though.

I'm going to have to look into that, as I ...
  Topic: Strange behavior, atmega88pa
Robert_d1968

Replies: 19
Views: 459

PostForum: BASCOM-AVR Archive   Posted: Tue Dec 18, 2012 3:10 pm   Subject: Strange behavior, atmega88pa
That would be correct,

I'm not doing any of that in this code.

Everything is just set up as:
Dim this as word
Dim that as byte

all at the beginning of the code


I did however play aroun ...
 
Page 4 of 5 Goto page Previous  1, 2, 3, 4, 5  Next
All times are GMT + 1 Hour
Jump to: