Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Search found 36 matches
www.mcselec.com Forum Index
Author Message
  Topic: Problem with Byte Value reported on 64bit Windows10
madhav1080

Replies: 9
Views: 458

PostForum: BASCOM-AVR   Posted: Wed Dec 19, 2018 7:09 am   Subject: Problem with Byte Value reported on 64bit Windows10
Are using the same Bascom version on both the windows versions?
Did you update the windows version or started over again? If you started over again are you sure that the ide settings are the same as ...
  Topic: Problem with Byte Value reported on 64bit Windows10
madhav1080

Replies: 9
Views: 458

PostForum: BASCOM-AVR   Posted: Wed Dec 19, 2018 6:31 am   Subject: Problem with Byte Value reported on 64bit Windows10
with just minor changes

that is not a real good approach when checking a problem.
first of all,(or second) it does not matter if you run on win7 or win10 and if it is 32 or 64 bit. (period)
simpl ...
  Topic: Problem with Byte Value reported on 64bit Windows10
madhav1080

Replies: 9
Views: 458

PostForum: BASCOM-AVR   Posted: Mon Dec 17, 2018 6:27 am   Subject: Problem with Byte Value reported on 64bit Windows10
There is no problem when we run the Simulator.

I have programmed the Chip ATMEGA32A firmware that is when this problem surfaced, When it works ok on the simulator and fouls up on the actual device ...
  Topic: Problem with Byte Value reported on 64bit Windows10
madhav1080

Replies: 9
Views: 458

PostForum: BASCOM-AVR   Posted: Sun Dec 16, 2018 4:50 pm   Subject: Problem with Byte Value reported on 64bit Windows10
Hello,

I have been a Bascom 8051 & Bascom AVR user for more than 10 years, Till recently was running BASCOM AVR on my 2009 MacBook Pro under Bootcamp 4.0 in Windows10 32 bit, had successfully u ...
  Topic: Timer2 Not Functional in ATMEGA164PA
madhav1080

Replies: 0
Views: 235

PostForum: BASCOM-AVR   Posted: Thu Oct 04, 2018 1:02 pm   Subject: Timer2 Not Functional in ATMEGA164PA
Hello,

I have observed that Timer2 when Initialized to work as Timer in ATMEGA164PA fails to run, doubting this I changed the controller to ATMEGA32A, the timer2 works fine with the same code compi ...
  Topic: Problems with ATMEGA164PA
madhav1080

Replies: 17
Views: 867

PostForum: BASCOM-AVR   Posted: Mon May 14, 2018 1:06 pm   Subject: Re: ATMEGA164PA Timer2 Issue
I am still not very clear about the PCINT2 triggered for the PORTB activity, maybe I should just write the code for testing this and then add the rest, on couple of occasions this helped solve such pr ...
  Topic: Problems with ATMEGA164PA
madhav1080

Replies: 17
Views: 867

PostForum: BASCOM-AVR   Posted: Mon May 14, 2018 12:25 pm   Subject: ATMEGA164PA PCINT2 Gets triggered with PORTB Activity
Hello,

I have fixed this problem doing the following...

upon Serial interrupt, first LIMIT PCINT2 by setting PCMSK2= &H00, process the action and set the PORTB accordingly, ENABLE PCINT2 by ...
  Topic: Problems with ATMEGA164PA
madhav1080

Replies: 17
Views: 867

PostForum: BASCOM-AVR   Posted: Mon May 14, 2018 2:51 am   Subject: ATMEGA164PA Timer2 Issue
Many many THANKS, I just needed confirmation on the Timer2 issue, sure will not use START TimerX to initiate the timers...

Noted your suggestion about setting the interrupt mode first and Then Ena ...
  Topic: Problems with ATMEGA164PA
madhav1080

Replies: 17
Views: 867

PostForum: BASCOM-AVR   Posted: Sun May 13, 2018 5:07 pm   Subject: ATMEGA164 Timer2 Issue
Well, this is from a system already in place, I am now adding mechanical switchs interface using the pin change interrupt, I have used pin change interrupt on ATMEGA88PA & ATMEGA328P in numerous ...
  Topic: Problems with ATMEGA164PA
madhav1080

Replies: 17
Views: 867

PostForum: BASCOM-AVR   Posted: Sun May 13, 2018 4:42 pm   Subject: Sorry for the double posts
This was definitely not intentional, I am using Internet explorer and could be an issue with it, you may have noticed that the first post was also twice.

I am truly sorry the Preview button is aut ...
  Topic: Problems with ATMEGA164PA
madhav1080

Replies: 17
Views: 867

PostForum: BASCOM-AVR   Posted: Sun May 13, 2018 10:51 am   Subject: ATMEGA164PA Timer2 Issue
As I had informed earlier, I had switched to using Timer1, For posting the code here I changed all Timer1 Instances to Timer2 and I forgot to change the Interrupt Vector branch out from Timer1 to Time ...
  Topic: Problems with ATMEGA164PA
madhav1080

Replies: 17
Views: 867

PostForum: BASCOM-AVR   Posted: Sun May 13, 2018 10:41 am   Subject: ATMEGA164PA Timer2 Issue
As I had informed earlier, I had switched to using Timer1, For posting the code here I changed all Timer1 Instances to Timer2 and I forgot to change the Interrupt Vector branch out from Timer1 to Time ...
  Topic: Problems with ATMEGA164PA
madhav1080

Replies: 17
Views: 867

PostForum: BASCOM-AVR   Posted: Sun May 13, 2018 10:28 am   Subject: ATMEGA164 Timer0 issue & PCINT2 Problems
Yes of course, I use Code Explorer, here is a screenshot from my computer...

Timer2 can be tested by assigning Del some value and calling an event like setting a port pin High or transmitting a kno ...
  Topic: Problems with ATMEGA164PA
madhav1080

Replies: 17
Views: 867

PostForum: BASCOM-AVR   Posted: Sun May 13, 2018 4:06 am   Subject: ATMEGA164PA Timer2 & PCINT2 (pin change) interrupt issue
Hello,

Since the Timer2 was not functional, I just modified the code to use Timer1, in this program. I am already using Timer0 for the 50Hz dimming using Zero cross hardware, Have no issues with Ti ...
  Topic: Problems with ATMEGA164PA
madhav1080

Replies: 17
Views: 867

PostForum: BASCOM-AVR   Posted: Sat May 12, 2018 9:26 am   Subject: Problems with ATMEGA164PA
Hello,

I have been using ATMEGA164PA since its launch in a Xbee to Modbus converters and must have delivered over 3000 units till date, in another of my products, a Home automation control for 4 re ...
 
Page 1 of 3 Goto page 1, 2, 3  Next
All times are GMT + 1 Hour
Jump to: