Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Search found 50 matches
www.mcselec.com Forum Index
Author Message
  Topic: Attiny441 Timer0 and Timer2 - PWM
kulisek

Replies: 0
Views: 469

PostForum: BASCOM-AVR   Posted: Mon Feb 27, 2017 12:39 am   Subject: Attiny441 Timer0 and Timer2 - PWM
Hi,

During testing PWM at Attiny441 I found out that this code give error:
Config Timer0 = Pwm , Compare A Pwm = Clear Up , Compare B Pwm = Clear Up , Prescale = 8
can be written only like this ...
  Topic: Attiny441 PWM ?
kulisek

Replies: 0
Views: 254

PostForum: BASCOM-AVR   Posted: Sun Feb 26, 2017 6:59 pm   Subject: Attiny441 PWM ?
Hi,

Please can anybody help with PWM at Attiny441 ? I need on ports TOCC0, TOCC1, TOCC2 to get standard 8 bit PWM

Thanks

(BASCOM-AVR version : 2.0.8.0. , Latest : 2.0.7.8 )
  Topic: IDE error
kulisek

Replies: 7
Views: 704

PostForum: BASCOM-AVR   Posted: Sun Dec 25, 2016 1:38 pm   Subject: IDE error
Hi,

In the newest version 2.0.8.0. is intersting error in IDE. Some lines are in gray color and in italic style - at some lines is italic only in some part.
If is inserted some line before changed ...
  Topic: TIMER1 as Monostable Multivibrator ?
kulisek

Replies: 1
Views: 211

PostForum: BASCOM-AVR   Posted: Wed Jun 15, 2016 11:43 pm   Subject: TIMER1 as Monostable Multivibrator ?
Hi,

Please can anybody help with this:

I would like to have Timer1 as adjustable monostable multivibrator. Processor Attiny4313, Xtal 16MHz. The trigerring input INT1, output OC1B with active hi ...
  Topic: Atmega162 USART interrupt
kulisek

Replies: 3
Views: 247

PostForum: BASCOM-AVR   Posted: Sun Feb 28, 2016 9:08 pm   Subject: Atmega162 USART interrupt
It is OK now.
  Topic: Atmega162 USART interrupt
kulisek

Replies: 3
Views: 247

PostForum: BASCOM-AVR   Posted: Sun Feb 28, 2016 8:50 pm   Subject: Atmega162 USART interrupt
Hi,

Does anybody know why this interrupt "On UCSR0A.RXC0 Read_serial" gives me error message: ""

for Atmega162 ?

Thanks

(BASCOM-AVR version : 2.0.7.8 )
  Topic: IR over UART ?
kulisek

Replies: 12
Views: 832

PostForum: BASCOM-AVR   Posted: Thu Oct 22, 2015 5:22 pm   Subject: IR over UART ?
I can generate 36 KHz from port PD4 and HW USART on port PD3


Tcd5_ctrle = 1
Tcd5_cca = 333 ' 36kHz output
Tcd5_ctrla = &H01
...
  Topic: IR over UART ?
kulisek

Replies: 12
Views: 832

PostForum: BASCOM-AVR   Posted: Mon Oct 19, 2015 9:27 pm   Subject: IR over UART ?
I want to use transfer only any standard bytes with 1200 bps - no protocol.
  Topic: IR over UART ?
kulisek

Replies: 12
Views: 832

PostForum: BASCOM-AVR   Posted: Mon Oct 19, 2015 12:26 pm   Subject: IR over UART ?
Hi,

I want transmit data with IR way over UART. The modulation frequency 36 Khz or 38 Khz. Can anybody help
how can I do it ? I want to use Atxmega32E5.

Thanks

(BASCOM-AVR version : 2.0.7.9 ...
  Topic: CONST already specified [_ROMSIZE] ?
kulisek

Replies: 1
Views: 128

PostForum: BASCOM-AVR   Posted: Wed Oct 14, 2015 4:02 pm   Subject: CONST already specified [_ROMSIZE] ?
Hi,

When I write this code and compile it I got error: CONST already specified $regfile = "xm128c3def.dat"

$crystal = 32000000
$hwstack = 50
$swstack = 50
$framesize = 50


How r ...
  Topic: Attiny441 USART REMAP ?
kulisek

Replies: 1
Views: 202

PostForum: BASCOM-AVR   Posted: Wed Jul 15, 2015 11:43 am   Subject: Attiny441 USART REMAP ?
Hi

At Attiny441 I want to use USART at PINB.2 - RXD0 instead default PINA.2 . Thus I wrote:

----------------------------------------------------------------------------------------------------- ...
  Topic: Atxmega2E5 USART enable / disable ?
kulisek

Replies: 1
Views: 225

PostForum: BASCOM-AVR   Posted: Mon May 04, 2015 12:58 pm   Subject: Atxmega2E5 USART enable / disable ?
Hi,

At Atxmega32E5 I need sometimes in program to use PORTD.3 for other putpose. When I use Usartd0_ctrlb = &B00000000 then I disable USART but pin is in low state and I can not
set it to ...
  Topic: LCD - something wrong
kulisek

Replies: 5
Views: 496

PostForum: BASCOM-AVR   Posted: Tue Feb 24, 2015 1:32 am   Subject: LCD - something wrong
It is OK now

T H A N K S ! ! !
  Topic: LCD - something wrong
kulisek

Replies: 5
Views: 496

PostForum: BASCOM-AVR   Posted: Mon Feb 23, 2015 7:37 pm   Subject: LCD - something wrong
The same problem is after CLS only When I rotate screen then are these pixels on the same place - random pixels are not rotated. Connection of LCD is as short as possible. All texts sent to LCD are O ...
  Topic: LCD - something wrong
kulisek

Replies: 5
Views: 496

PostForum: BASCOM-AVR   Posted: Mon Feb 23, 2015 3:43 pm   Subject: LCD - something wrong
Hi,

I use LCD with ST7565R driver 128*64. I use glcdEADOGM128x6.lbx. Almost all is OK but at left side of LCD are shown some random pixels.
Can anybody told me what is it ? I tested 3 LCD with the ...
 
Page 1 of 4 Goto page 1, 2, 3, 4  Next
All times are GMT + 1 Hour
Jump to: