Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Search found 1932 matches
www.mcselec.com Forum Index
Author Message
  Topic: Version 2084
MWS

Replies: 11
Views: 720

PostForum: BASCOM-AVR   Posted: Mon Jul 12, 2021 7:59 am   Subject: Re: Error whit "Rainbow-LIB"
I think that the new routine probably does not cope with the 128k Flash.
The 128k is no problem, either it's a) different helper code which stretches the 'relative' in RCALL too much, i.e. more than ...
  Topic: time(clock_sys) produces HH:MM:SS in Hex!
MWS

Replies: 4
Views: 182

PostForum: BASCOM-AVR Unsupported versions   Posted: Fri Jul 09, 2021 7:45 am   Subject: Re: time(clock_sys) produces HH:MM:SS in Hex!
time$ = time/clock_sys)
Time$ expects a string and not the result of a division, and as Evert wrote: multiple consecutive assignments to the same variable are nonsense.
Thus it's to assume this ...
  Topic: Request Help, Don't have font files on my system under sampl
MWS

Replies: 4
Views: 119

PostForum: BASCOM-AVR   Posted: Tue Jul 06, 2021 12:21 pm   Subject: Request Help, Don't have font files on my system under sampl
Copy font- and image files in the same directory as your .bas-file.
  Topic: How to alias a variable
MWS

Replies: 5
Views: 166

PostForum: BASCOM-AVR   Posted: Mon Jul 05, 2021 11:57 pm   Subject: Re: How to alias a variable
I didn't ask why the code I made didn't work
That was for free, you're welcome.
  Topic: How to alias a variable
MWS

Replies: 5
Views: 166

PostForum: BASCOM-AVR   Posted: Mon Jul 05, 2021 4:29 pm   Subject: How to alias a variable
Better try like this.
Porta = Porta Or Helpb
Better not.

Given:
Led_Port = &B1000_0100
PortA = &B0100_0010
Exec:
Helpb = Led_port And &B0000_1111
'-> HelpB: &B ...
  Topic: How to alias a variable
MWS

Replies: 5
Views: 166

PostForum: BASCOM-AVR   Posted: Mon Jul 05, 2021 3:01 pm   Subject: Re: How to alias a variable
If defined like this, if &HF0 is set to Led_Port, the LED connected to PortB.0~3 is turned on, and if &H0F is set, the LED connected to PortA.0~3 is not turned on?
Your code does not work and ...
  Topic: Problem with Delchar
MWS

Replies: 3
Views: 130

PostForum: BASCOM-AVR   Posted: Fri Jul 02, 2021 3:42 pm   Subject: Re: Problem with Delchar

delchar eval_string_0, 1
delchar eval_string_0, 2
...
delchar eval_string_0, 15

I'd say if your intention is to write maximal inefficient code, you're on your way.

To solv ...
  Topic: atmega32u4 and timer interrupt
MWS

Replies: 7
Views: 189

PostForum: BASCOM-AVR   Posted: Tue Jun 29, 2021 2:36 pm   Subject: atmega32u4 and timer interrupt
MWS - absolutely righ Smile I had to mix something during copy-paste
I ask because it's hard to judge from mixed code to the real code, especially if there is more 'mix'.

Does the encoder Int1 fire? ...
  Topic: atmega32u4 and timer interrupt
MWS

Replies: 7
Views: 189

PostForum: BASCOM-AVR   Posted: Tue Jun 29, 2021 12:17 pm   Subject: Re: atmega32u4 and timer interrupt
Print Impulsyanie timer0_int żeby zapisać stan licznika impulsatora do eepromu  
It would be odd if it would compile.
  Topic: atxmega128a3u problem with TWID and TWIF
MWS

Replies: 15
Views: 260

PostForum: BASCOM-AVR   Posted: Thu Jun 17, 2021 9:45 am   Subject: atxmega128a3u problem with TWID and TWIF
OK Smile .... You knew but I didn't write .
Sure. It is my habit to check how my discussion partner reacts to my hints. My hint about overclocking was a valid one.
As you showed to be a loose canon, w ...
  Topic: atxmega128a3u problem with TWID and TWIF
MWS

Replies: 15
Views: 260

PostForum: BASCOM-AVR   Posted: Thu Jun 17, 2021 6:57 am   Subject: atxmega128a3u problem with TWID and TWIF
msw ...are you blind ? Mark wrote the answer!...answer 100% correct and solve the problem
I noticed that.
But to be fair, one needs to say there never was a problem, as the controller behaved exact ...
  Topic: atxmega128a3u problem with TWID and TWIF
MWS

Replies: 15
Views: 260

PostForum: BASCOM-AVR   Posted: Thu Jun 17, 2021 2:35 am   Subject: atxmega128a3u problem with TWID and TWIF
I'm not interested in your imaginary car problems .
Looks like you did not read the manual of your car, lol.
I wrote that- xmega works without any problems with usart,spi,timers,sdcard,lcd,external ...
  Topic: atxmega128a3u problem with TWID and TWIF
MWS

Replies: 15
Views: 260

PostForum: BASCOM-AVR   Posted: Wed Jun 16, 2021 7:01 pm   Subject: atxmega128a3u problem with TWID and TWIF
If you'd know the answers, you would not need to ask.
It is not problem 60MHz for xm128a3u .
If my car's engine can do 5000 rpm, then 10000rpm is no problem.
Moot to discuss errors, which may resu ...
  Topic: atxmega128a3u problem with TWID and TWIF
MWS

Replies: 15
Views: 260

PostForum: BASCOM-AVR   Posted: Wed Jun 16, 2021 6:08 pm   Subject: Re: atxmega128a3u problem with TWID and TWIF
$CRYSTAL = 60000000 '60MHz
Not every wish meets reality.
  Topic: probleme sur bit1 du portD atmega823P
MWS

Replies: 18
Views: 484

PostForum: BASCOM-AVR   Posted: Mon May 31, 2021 3:21 pm   Subject: probleme sur bit1 du portD atmega823P
you know everything, and I'm a moron.
Surly not. Not the one, not the other.
I'm wondering why you are so inflexible if you get something incorrect.
Happens to anyone of us, but staying stubborn in ...
 
Page 1 of 129 Goto page 1, 2, 3 ... 127, 128, 129  Next
All times are GMT + 1 Hour
Jump to: