Forum - MCS Electronics

 

FAQFAQ SearchSearch RegisterRegister Log inLog in

Search found 81 matches
www.mcselec.com Forum Index
Author Message
  Topic: USI, TWI, I2C confusion
AlanGHosler

Replies: 6
Views: 799

PostForum: BASCOM-AVR   Posted: Sat Jan 27, 2018 3:48 am   Subject: I2C MSC slave library
If you are interested, I have posted codes under "Post your working BASCOM AVR code here" that show how I used the MSC library to communicate between a ATmega1284 (as the master) and a ATtiny861A (as ...
  Topic: Sending a LinkSprite jpeg File as MMS Using a SIM5216A
AlanGHosler

Replies: 12
Views: 1325

PostForum: Share your working BASCOM-AVR code here   Posted: Thu Dec 14, 2017 4:52 pm   Subject: Sending a LinkSprite jpeg File as MMS Using a SIM5216A
The attached BASOM file, “SIM5216A_Spinel forum” updates my ATmega1284 program so that it will take pictures using the highest resolution the Spinel camera provides, 1600 x 1200. In this regard there ...
  Topic: Sending a LinkSprite jpeg File as MMS Using a SIM5216A
AlanGHosler

Replies: 12
Views: 1325

PostForum: Share your working BASCOM-AVR code here   Posted: Wed Nov 29, 2017 1:14 am   Subject: Spinel and LinkSprite Serial jpeg Cameras
I have continued to expand this project but didn’t plan to post any more updates as I didn’t believe they would be that useful to BASCOM Forum members. However, recently the makers of Spinel cameras ...
  Topic: KamPROG Problem with the ATMega1284
AlanGHosler

Replies: 3
Views: 137

PostForum: BASCOM-AVR   Posted: Sun Nov 26, 2017 10:47 pm   Subject: KamPROG Reading Signature Bytes
Sorry Mark I wasn’t clear about KamPROG vs BASCOM. Because of my earlier problems with the KamPROG programmer, I decided to start off running KamPROG as a standalone program and get that working befor ...
  Topic: KamPROG Problem with the ATMega1284
AlanGHosler

Replies: 3
Views: 137

PostForum: BASCOM-AVR   Posted: Sat Nov 25, 2017 10:04 pm   Subject: KamPROG Problem with the ATMega1284
Mark, thank you for the response to my previous posting regarding the KamPROG “EnhancedPowerManagementEnable” problem.
With regard to the KamPROG programmer not recognizing the ATmega1284 chip, I am ...
  Topic: KamPROG Enhanced Power Management message Fixed
AlanGHosler

Replies: 1
Views: 134

PostForum: BASCOM-AVR   Posted: Fri Nov 24, 2017 3:42 pm   Subject: KamPROG Enhanced Power Management message Fixed
A couple of years ago I purchased a KamPROG which I have never been able to get to work for me. With Bascom 2.0.8.0 providing increased support for the KamPROG I decided to restart my efforts. They ga ...
  Topic: Slave lib
AlanGHosler

Replies: 4
Views: 421

PostForum: BASCOM-AVR   Posted: Thu Jan 26, 2017 5:00 pm   Subject: I2C library
You might look at an update I just posted (1/26/2017) in the Working AVR code forum. It shows how I have used the library for an ATtiny861. Be certain in the coding for the slave that you do not incl ...
  Topic: Use of the MCS I2C Slave Library
AlanGHosler

Replies: 2
Views: 824

PostForum: Share your working BASCOM-AVR code here   Posted: Thu Jan 26, 2017 4:55 pm   Subject: Update to I2C Slave Program
Previously I only included a portion of my program. Attached is the latest version of the entire program that uses the MSC I2C slave library. In a separated posting I will provide the circuit diagra ...
  Topic: Problem with the MCS Add On I2C Slave Library
AlanGHosler

Replies: 2
Views: 182

PostForum: BASCOM-AVR   Posted: Tue Nov 22, 2016 4:28 pm   Subject: Problem fixed
Thanks Mark; I posted the message then went to pour some more coffee (I got up at 1:30 am to work more on this) and there was your reply when I returned which solved my problem in both my test progra ...
  Topic: Problem with the MCS Add On I2C Slave Library
AlanGHosler

Replies: 2
Views: 182

PostForum: BASCOM-AVR   Posted: Tue Nov 22, 2016 3:22 pm   Subject: Problem with the MCS Add On I2C Slave Library
I have been dealing with a problem using the MCS add on slave library for many days and I have been able to reduce the problem to the very short and simple code provided below. The problem is that wh ...
  Topic: Sending a LinkSprite jpeg File as MMS Using a SIM5216A
AlanGHosler

Replies: 12
Views: 1325

PostForum: Share your working BASCOM-AVR code here   Posted: Thu Oct 27, 2016 4:42 pm   Subject: Baud Rate
Mark:

I will try those two ideas although the reason for using the 14.7456 MHz oscillator is that it should have zero error for any baud rate.

Alan
  Topic: Sending a LinkSprite jpeg File as MMS Using a SIM5216A
AlanGHosler

Replies: 12
Views: 1325

PostForum: Share your working BASCOM-AVR code here   Posted: Thu Oct 20, 2016 8:26 pm   Subject: LinkSprite SIM5216A Update Using an ATMega168
I previously posted this SIM5216A project using an ATMega 2560. I have decided that it will work best for me to have one printed circuit board (PCB) running a ATMega168 that only sends SMS messages an ...
  Topic: Problems with AVR programmers and windows 10
AlanGHosler

Replies: 8
Views: 980

PostForum: AVR   Posted: Tue May 03, 2016 3:43 pm   Subject: AVRISP
That is correct, it does not work with Studio 4.19. So until I get that problem resolved, as I understand it, there is no reason to deal with libusb-win32.
  Topic: Problems with AVR programmers and windows 10
AlanGHosler

Replies: 8
Views: 980

PostForum: AVR   Posted: Tue May 03, 2016 4:34 am   Subject: AVRISP
Thanks Mark

I did all of that. libusb-Win32 seemed to run okay. However in Device Manager the "AVRISB mkii" is listed separately under "libusb-Win32" rather than under "Jungo" (which does contai ...
  Topic: Problems with AVR programmers and windows 10
AlanGHosler

Replies: 8
Views: 980

PostForum: AVR   Posted: Mon May 02, 2016 3:36 pm   Subject: AVRISP not Working
My AVRISP Mkii worked for a while with Windows 10 then stopped in early April 2016. It does work on another computer running an earlier version of windows.

I do not find the "LIBUSB***" file in C: ...
 
Page 1 of 6 Goto page 1, 2, 3, 4, 5, 6  Next
All times are GMT + 1 Hour
Jump to: